Resolved
The slow loading issue should now be resolved. Thank you for your patience. If any further issues regarding this come up, please reach out to our support team.
Investigating
We're investigating long loading times when accessing Lovable. Multiple users have reported that the Lovable dashboard and projects are taking a long time to load or not loading at all.