Resolved
The issue causing custom domains to get stuck on "Setting up" has been resolved. All affected domains should now automatically become live. If yours is still stuck, try removing and re-adding it to your project.
Monitoring
We've identified the issue and fixed it. All new domains added will not get stuck and instead set up correctly. If your domain got stuck, please remove it and add it back again to set it up correctly.
Investigating
We are investigating an issue where custom domains are stuck on the "Setting up" stage. Thank you for your patience.