Resolved
This incident has been resolved. Google connector authorizations are now working as expected again.
Identified
We've identified the root cause as a rate limit issue and are working on a full resolution. Some authorizations of new Google connector connections are still failing, while others are succeeding. Existing Google connections are unaffected. We'll keep you updated.
Investigating
We've identified that this issue is affecting all Google connectors, not just Google Search Console as initially stated. Users are currently receiving a rate_limit_exceeded error when attempting to connect. We're actively working on a resolution and will keep you updated.
Investigating
We're investigating an issue affecting users connecting the Google Search Console connector to their accounts. Users are currently receiving a rate_limit_exceeded error. We're actively working on a resolution and will update you shortly.