Resolved
The issue with the service provider is resolved and Cloud projects are back to normal functionality. Sorry for the earlier inconvenience.
Investigating
We're currently experiencing an issue with one of our service providers that is affecting Cloud projects. We're investigating and will keep you posted.