We monitored recovery
Resolved
Our 3rd party provider solved it and it is now fixed
Investigating
Some project builds are currently failing. We are investigating and working to restore normal operation.