Resolved
Login via Google is now working again for users who were previously impacted in Eastern Europe.
Identified
The issue seems to be mostly affecting EMEA
Identified
We are currently experiencing login issues due to a widespread outage affecting Google Workspace services. As a result, users who sign in using Google may be unable to access their accounts at this time. This issue appears to be impacting multiple services across Eastern Europe and is outside of our direct control. We are monitoring the situation closely and will provide updates as more information becomes available. For the latest status from Google, please visit: https://www.google.com/appsstatus/dashboard/ We apologize for the inconvenience and appreciate your patience while we await resolution from Google.