Resolved
Claiming Shopify stores are back to normal now. Failed claim operations are successfully processed.
Investigating
The Shopify store claim functionality is currently non-functional for Lovable users with Shopify integration enabled. The integration itself remains operational, but users cannot complete the store claiming process. Shopify has been contacted and investigation is ongoing.