Resolved
We've identified the issue and routed to another provider. The system has recovered.
Investigating
We are currently experiencing elevated internal error rates. Our engineering team is actively investigating the root cause and working to resolve this as quickly as possible.