Resolved
The agent was processessing the first follow-up in the queue but the second follow-up were remaining stuck indefinitely. This is now resolved.
Investigating
Due to a recent regression, the agent fails to pick up enqueued messages. We're working on fixing the problem. In the meantime, a workaround is to pause the queue and send messages directly without using the queue.