Custom domains added recently were failing to fully activate because their security certificates could not be issued. This has now been resolved, and affected domains should complete setup normally; if a domain still is not active, removing and re-adding it will retry the process.
Resolved
Custom domains added recently were failing to fully activate because their security certificates could not be issued. This has now been resolved, and affected domains should complete setup normally; if a domain still is not active, removing and re-adding it will retry the process.
Resolved
The issue has now been resolved and users should be able to set up custom domains as expected.
Investigating
We're currently experiencing an issue with custom domains where SSL certificates are failing to provision for user-added custom domains. This might cause the domain to not become active after setup. Our team is actively working with our infrastructure provider to resolve this, and we expect to have an update within the next few hours.